暗黑靈獸降臨!【點我參戰】比潔哥30公分還驚人造型太多!忍不住瘋狂自拍!史上最強遊戲重金邀請你加入
cadatw ( cadatw ) Lv. 2 | 文章數 : 27
2
第 1 篇 2006-11-04 07:54:03
首先須聲明,這項發現不是我獨創,各相關網站早已有所討論。 
各位如想試試看,請先以搜尋的方式找尋VMware Workstation的相關教學 , 
否則您大概會看不懂我在說什麼。 
建議參考此網址的教學資料,有VMware安裝設定的圖文解說: 
http://www.pcdvd.com.tw/showthread.php?t=574463&page=1&pp=10  
在此先簡單說明所謂的VMware Workstation,這是俗稱的虛擬機器,也就是在 
目前的作業系統(至少需XP系統)安裝此軟體,而這軟體就可模擬出一部虛擬 
(假的)電腦,雖然是虛擬的電腦,但卻可以當真的用,所以就可以在這部假 
電腦再安裝另一套作業系統,這個作業系統跟原來的系統是各自獨立的,也同 
樣可以上網,所以您就可在真的電腦上執行一個楓之谷遊戲,在 這部假電腦又 
可執行另一個楓之谷,就好像您同時擁有兩部電腦。 
不過,請別高興的太早,既然是一部電腦當兩部用(如果您的電腦很夠力,同 
時存在三、四部都可以),在這部虛擬電腦上玩遊戲,尤其楓之谷要求需有3D 
加速卡的,無論您的電腦多有力,恐怕都不會太順暢,還好,一般會需要同時 
開兩個楓之谷,大都是為了自己的人物交換道具,或自己帶自己的人物練功, 
在虛擬電腦上的遊戲,大都不需有很多動作,如果您的要求不高,就玩玩看吧 

先決條件: 
1.電腦要很夠力,我所用的電腦只1.41Ghz,896MB RAM,事實上跑的很不順, 
  所以建議至少2.5Ghz以上,1G的RAM。  
2.真機器的作業系統是XP或2000/2003才能安裝VMware Workstation 5.5.2版。  
3.在虛擬機器上安裝的作業系統也必須是XP或2000/2003,大陸相關討論提到需 
  安裝2000/2003才可以在虛擬系統跑楓之谷,我實際測試的結果,安裝XP也可 

設定重點: 
這是關鍵了,因為VMware Workstation 所模擬的顯示卡內定是不支援3D的,所 
以如不加修改,在此模擬系統是無法跑楓之谷,請依下列方式處理。 
1.在虛擬機器先灌好作業系統(需給這個系統命名,及指定實際要放在真電腦上 
  的哪個目錄),灌好後請先將虛擬系統電腦關機,然後在上述目錄內找副檔名 
  是.vmx的檔案,例如我是給這個虛擬系統命名為VMXP,就可找到一個VMXP.vmx 
  的檔案,此檔是一般文字檔案,可用記事本開啟,請加入以下三行, 
  mks.enable3d = TRUE  
  svga.vramSize = 67108864  
  vmmouse.present = FALSE  
  第一行是讓虛擬系統可以模擬3D卡 
  第二行svga.vramSize = 67108864 是表示這個模擬3D卡是64M Ram 
  第三行是為了某些遊戲所加的項目,請再更改下列設定  
    a. 在工具列選 Edit > Preferences.  
    b. 按 Input.  
    c. 取消 Ungrab when cursor leaves window.  
2.再次將虛擬系統開機,在虛擬機器上方工具列VM內有個install VMware tools   
  執行它就可安裝VMware tools,安裝完成會要求虛擬系統重開機,重開機完成 
  後請在虛擬系統的開始->執行->打入Dxdiag,這可啟動DirectX 診斷工具,在 
  〔顯示〕這部份,查看是否顯示Drect3D加速: 已啟動,如果顯示已啟動,那 
  就代表可以支援3D了。 
3.在虛擬系統安裝〔楓之谷〕,大功告成。 
PS,VMware Workstation 5.5.2是版權軟體(未註冊好像可試用30天),會使用 
emule 的,就搜尋看看吧^^ 
能否請機器較高級的大大玩玩看,然後報告是否能玩的順暢,我的機器太爛,在 
人物移動時頓頓的,而且遊戲內的滑鼠游標有時會亂飄。

--本文在2006/11/08 19:41:15被編輯過

臉書回應

來源IP:220.134.152.* [ 檢舉此文 ]
falcon_vader ( Falcon Vader ) 戀戀玫瑰花束 Lv. 17 | 文章數 : 895
1
第 2 篇 2006-11-06 22:53:07
首先我要謝謝你
因為我也試過VMware也試過Connectix Virtual PC
結果都是卡在Direct 3D的問題
經過你的資料蒐集和分享
我的確成功的證實了你所說的是可行的

  mks.enable3d = TRUE 
  svga.vramSize = 67108864 
  vmmouse.present = FALSE
這三句設定也沒問題
經查VMware說明文件
也是確實有效的指派
尤其是您提到的第三行
來自官網的文獻:
http://www.vmware.com/support/ws5/doc/ws_vidsound_d3d_enabling_vm.html
其中特別指出關於滑鼠的設定
對於全螢幕3D線上第一人稱遊戲
能夠使用遊戲之中專屬的滑鼠指標
而不是來自原本真實電腦裡面的滑鼠指標
所以這第3行設定有其必要性
簽名檔
好友可以刪除、等級不能不練
--------------------------
伺服位址:木妖
箭神(2008已封頂)主教(151等)拳霸(136等)黑騎(131等)主教(120等)
來源IP:220.132.174.* [ 檢舉此文 ]
cadatw ( cadatw ) Lv. 2 | 文章數 : 27
0
第 3 篇 2006-11-08 01:43:48
有找到很詳盡的解說,包括如何設定VMware

http://www.pcdvd.com.tw/showthread.php?t=574463&page=1&pp=10

請詳看他的討論且有圖文解說



快速回文 | 註冊
討論板頭像 [ 設定:] |簽名檔 [ 設定:]
有人回覆時通知我 【通知管理